[ros-users] rosinstall problems on Debian

Taylor Veltrop taylor at veltrop.com
Mon Feb 14 12:00:18 UTC 2011

Embarrassed to say that I can't get the newest rosinstall working on  
my machine, using Debian lenny 5.0.8 and the standard source based  
install instructions at http://www.ros.org/wiki/cturtle/Installation/Debian 
.  Python version is 2.5.2.

sudo apt-get install build-essential python-yaml cmake subversion wget  
sudo easy_install -U rosinstall

When I run:
rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=cturtle&variant=base&overlay=no 

Here is the output:
veltrobot:~ $ rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=cturtle&variant=ros_only&overlay=no 
rosinstall/vcs/svn.py:49: Warning: 'with' will become a reserved  
keyword in Python 2.6
Traceback (most recent call last):
   File "/usr/bin/rosinstall", line 5, in <module>
     pkg_resources.run_script('rosinstall==0.5.15', 'rosinstall')
   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 448,  
in run_script
     self.require(requires)[0].run_script(script_name, ns)
   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line  
1173, in run_script
     exec script_code in namespace, namespace
   File "/usr/bin/rosinstall", line 28, in <module>

   File "/usr/lib/python2.5/site-packages/rosinstall-0.5.15-py2.5.egg/ 
rosinstall/vcs/svn.py", line 49
     with open(os.devnull, 'w') as fnull:
SyntaxError: invalid syntax

If I download the old http://www.ros.org/rosinstall and do a
./rosinstall ~/ros "http://www.ros.org/rosinstalls/cturtle_base.rosinstall 
then it all works out fine as it used to.

I found an old thread with the same error message from an ArchLinux  
user.  They fixed it by changing a python 3 symlink to a 2.7 symlink.   
That does not apply in my case.

Sorry if this has been covered before, I feel like it's something  
obvious but I haven't been able to find a solution.

Is Debian lenny's python the problem?

Taylor Veltrop

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110214/8fc692f9/attachment-0002.html>

More information about the ros-users mailing list