[ros-users] 'rviz' received an X Window System error

hitesh dhiman hitesh.dhiman.1988 at gmail.com
Mon Feb 21 16:20:19 UTC 2011

Hi all,
I'm running ROS CTurtle on Arch Linux.
I'm having trouble running rviz. The graphics card config is as follows:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile
GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c).
To check OpenGL support, i tried GlxGears, it works at about 60 fps.
However, when i run rviz, i get the following error:

[ INFO] [1298304143.204334812]: Loading general config from
[ INFO] [1298304143.204945577]: Loading display config from
The program 'rviz' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXBadDrawable'.
  (Details: serial 16 error_code 171 request_code 154 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The rviz splash pic appears and then disappears.
Is this a bug in rviz or something wrong with Ogre? Any help would be


Hitesh Dhiman
B. E. Electrical Engineering (Year 4)
National University of Singapore
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110222/6d3d82d4/attachment-0002.html>

More information about the ros-users mailing list