[ros-users] Error while running a simple server client program in flowdesigner

Ashwin V Kamath ashwin24udp at gmail.com
Tue Jun 7 16:21:26 UTC 2011

i am trying to run the following tutorial

but i get the following error and the program stops abruptly:

[ INFO] [1307457046.525074887]: Connected to master at [localhost:11311]
ROS node : HARK_MASTER_NODE generated...
/dev/rtc: Permission denied
Cannot open /dev/rtc
ioctl: Bad file descriptor
node_RosAddHarkIntClient_1 constructor end...
node_RosAddHarkIntClient_1 initialized...
node_RosAddHarkIntServer_1 initialized...
ROS initialized...
Segmentation fault

since i was having issues with permissions i tried using sudo and ran the
file in terminal,but i get the following error;

ROS_ROOT is not set!  Using default rosconsole configuration values
Scanning def /usr/lib/flowdesigner/toolbox
done loading def files
loading XML document from memory
Building network  :MAIN
[FATAL] [1307457375.864763327]: ROS_MASTER_URI is not defined in the
environment. Either type the following or (preferrably) add this to your
~/.bashrc file in order set up your local machine as a ROS master:

export ROS_MASTER_URI=http://localhost:11311

then, type 'roscore' in another shell to actually launch the master program.

[FATAL] [1307457375.864837707]: BREAKPOINT HIT
        file =


Trace/breakpoint trap

i exported the ROS_MASTER_URI variable in the .bashrc file and started
roscore in a new terminal.but the result is same.i still get the same
error.Can some one please tell me how to resolve this issue.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110607/3e5baaa6/attachment-0001.html>

More information about the ros-users mailing list