[ros-users] ROS for Windows via the mingw cross compiler

Morgan Cormier MCormier at coroware.com
Sat Mar 12 00:44:55 UTC 2011


Thanks for this reply,

I think the second error I had is because mingw didn't finish to compile because of the checksum error in libpng. I compiled it during the night, I didn't see the result since my computer shut down automatically, but since I could do the following step I though it was installed. 

I tried to do as you said, I did an svn update of eros and so had the lasest version, and tried to compile again mingw_cross but I had the same problem. 
Is the "svn co link" command enough or do I have to use the command "rosinstall /opt/ros https://code.ros.org/gf/project/eros/scmsvn/?action=browse&path=%2F*checkout*%2Ftrunk%2Feros_diamondback.rosinstall" ?

Thank you for your help,

Morgan Cormer

On 2011-03-11 14:31, Daniel Stonier wrote:
> On 11 March 2011 07:16, Morgan Cormier <MCormier at coroware.com> wrote:
> > Hi,
> >
> > I am interested in doing a Qt interface with ROS and found this tutorial which does exactly what I want :
> > http://www.ros.org/wiki/mingw_cross/Tutorials/cross_platform_qt_ros
> >
> > I experience some problems during the installation. When i compile mingw_cross (roscd mingw_cross;make) the compilation stop after downloading libpng, it says that the checksum is wrong.
> >
> > I installed it using : http://mingw-cross-env.nongnu.org/  and could finally do all the steps in the tutorial.
> > Another problem occured at this point, I couldn't compile because of this error :
> >
> > /opt/mingw/usr/i686-pc-mingw32/lib/libboost_signals-mt.a: member /opt/mingw/usr/i686-pc-mingw32/lib/libboost_signals-mt.a(trackable.o) in archive is not an object
> >
> > Do you know how to solve this problem?
> >
> > Thank you,
> >
> Just a quick reply before I crash for the night - will look at it
> again tomorrow.
> libpng checksum : we found a couple of broken link problems like this
> a couple of weeks ago, but that was because we were using mingw_2.16
> which was a bit dated. I upgraded the links in eros to actually use
> that tarball you downloaded (version 2.18), so can you make sure you
> reinstall, or at least svn update your eros again? We've fixed one or
> two other bugs in the meantime as well that you might need.
> The latter problem is a bit harder - I haven't come across that one
> before. Some links that might be relevant:
> http://www-01.ibm.com/support/docview.wss?rs=4036

More information about the ros-users mailing list