[ros-users] Pyyaml using easy_install on Mac OS X

S.Sudarshan sudarshan85 at gmail.com
Mon Mar 14 01:59:13 UTC 2011


Thanks for your replies.

I also had some trouble with yaml on my Mac. I solved it by installing
> py26-yaml:
> sudo port install py26-yaml
> I'm using python2.6 on OS X 10.6.
> Hope this helps!
> Gonçalo Cabrita
> ISR University of Coimbra
> Portugal

I installed py26-yaml and tried easy_install again..no luck same error.

These problems are usually related to confusion between the version of
> python that ships with Mac OS and the one that is installed by
> Macports.  For example, you might be installing yaml for one, and
> running the other, which subsequently can't find it.  So, I would
> double-check to make sure you're installing yaml in the Macports
> version of python 2.6 and running the same version. Try "sudo
> python_select python26" if you haven't already, and try re-running
> easy_install.  Also, /opt/local/bin should appear in your path before
> /usr/bin.  Make sure you get /opt/local/bin/python when you run 'which
> python' at a terminal.

"which python" gives me /usr/bin/python and not "/opt/local/bin". How can I
make it so that it looks at /opt/local/bin?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110313/cb9c2a5c/attachment-0003.html>

More information about the ros-users mailing list