[ros-users] tf problem in ubuntu natty

Pablo Urcola urcola at unizar.es
Fri May 13 09:00:31 UTC 2011


I am having some problems with tf in mynew ubuntu system (11.04).
When I run two or more nodes publishing transform messages, the tf 
system stops working properly.
I use a launch file with two static_transform_publisher nodes from tf 
package as follows:

<node name="localization" pkg="tf" type="static_transform_publisher" 
args="0 0 0 0 0 0 1 map odom 100"/>
<node name="rxl" pkg="tf" type="static_transform_publisher" args="0.16 0 
0.4 0 0 0 1 base_link laser_link 100"/>

As a result, topic tf do not work as expected.  Sometimes it works well 
but, for a while it only publishes one of the transforms or even none of 
This can be appreciated by echoing the /tf topic or by using view_frames 
node from tf package.

This configuration works perfectly on a ubuntu maverick installation, 
but we have tried in two different ubuntu natty computers and the 
problem is still there.

Has anyone noticed this behavior?



More information about the ros-users mailing list