[ros-users] Catkin Eclipse Integration

Gray Thomas gthomas at ihmc.us
Mon Jul 29 15:52:13 UTC 2013

Have you tried a previous version of eclipse? I switched from Helios to
Indigo when I had a similar problem using the point cloud library packaged
with ros (using rosbuild, admittedly) and the switch solved my indexing

*Gray Thomas,
*Robotics Researcher
40 S Alcaniz St. Pensacola, FL, 32502

On Sun, Jul 28, 2013 at 6:39 PM, Andre Barcelos <barcelos.andre at yahoo.com>wrote:

> Hi all,
> I`m trying to use Eclipse with Catkin. I`m having some problems with
> Index, for example, I have just tried to do this tutorial:
> http://www.ros.org/wiki/pcl/Tutorials and Eclipse doesn`t recognizes the
> index to "sensor_msgs::PointCloud2" (all these type).
> I`m able to compile the package into Eclipse(CTRL+B), it is working fine,
> my problem is with the Eclipse indexer.
> My steps to make Eclipse "works" on catkin were:
> $cd ~/catkin_ws
> $catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles"
>   $source ~/catkin_ws/devel/setup.bash
> $eclipse
> File -> Import -> General -> Existing Projects into Workspace...
>  When I open the .cpp file, I got some errors:
> Type 'sensor_msgs::P**ointCloud2' could not be resolved
> Type 'sensor_msgs::P**ointCloud2Const**Ptr' could not be resolved
> ...
> But, how I said, I`m able to compile the package, I just have NOT the
> indexes for this type.
>  Can you guys help me to make Eclipse index this?
> Thank you,
> Andre Barcelos.
> M.Sc Student
> Military Institute of Engineering
> Rio de Janeiro - Brazil
> .:
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20130729/af4ac323/attachment-0004.html>

More information about the ros-users mailing list