[ros-users] Error after last ROS updates

Enrico Corvaglia enrico988 at gmail.com
Tue Jan 13 13:08:11 UTC 2015

Thanks Mike,
but I've already tried your solution. By the way, reading the error
carefully I noticed that the path of the library is parsed as
The problem seems to lie in the double // after lib, maybe after a change
in the catkin package source code. Unfortunately I didn't succeed to solve
this issue yet.

2015-01-13 13:31 GMT+01:00 Mike Purvis <mpurvis at clearpathrobotics.com>:

> That does look like an ABI problem. Did you definitely sudo apt-get
> dist-upgrade, and then rebuild your workspace (eg, rm -rf build devel;
> catkin_make; source devel/setup.bash)?
> (This type of question is best for ROS Answers, I think...)
> On 13 January 2015 at 06:28, Enrico Corvaglia <enrico988 at gmail.com> wrote:
>> Hello to all the community.
>> I'm writing this since I'm encountering errors when I launch my custom
>> controllers written for a KUKA LWR arm, used in combination with Gazebo
>> simulator. The error comes when I run the roslaunch command which loads
>> such controllers.
>> *[ERROR] [1421148091.366974261, 5.814000000]: Could not load class
>> kuka_controllers/BacksteppingController: Failed to load library
>> /home/enrico/catkin_ws/devel/lib//libkuka_controllers.so. Make sure that
>> you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and
>> that names are consistent between this macro and your XML. Error string:
>> Could not load library (Poco exception =
>> /home/enrico/catkin_ws/devel/lib//libkuka_controllers.so: undefined symbol:
>> _ZN26forward_command_controller24ForwardCommandControllerIN18hardware_interface20EffortJointInterfaceEE8startingERKN3ros4TimeE)*
>> *[ERROR] [1421148091.367239553, 5.814000000]: Could not load controller
>> 'BacksteppingController' because controller type
>> 'kuka_controllers/BacksteppingController' does not exist.*
>> *[ERROR] [1421148091.367296142, 5.814000000]: Use 'rosservice call
>> controller_manager/list_controller_types' to get the available types*
>> The weird thing is that running the command suggested by ROS (rosservice
>> call [...]) it actually returns all my controllers names. This error has
>> been introduced after the last ROS software updates and before that it was
>> working just fine. Also I have a call to PLUGINLIB_EXPORT_CLASS in my
>> source, so it is not that the problem.
>> As a note, the ROS built-in position controllers work, so it seems like a
>> linking or a parsing error.
>> Thanks in advance,
>> Enrico C.
>> _______________________________________________
>> ros-users mailing list
>> ros-users at lists.ros.org
>> http://lists.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing list
> ros-users at lists.ros.org
> http://lists.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20150113/a58236c7/attachment.html>

More information about the ros-users mailing list