[ros-users] [Discourse.ros.org] [TurtleBot] TurtleBot3 software and firmware update and 'waffle_pi'

tosandip ros.discourse at gmail.com
Thu Feb 8 03:31:54 UTC 2018

Thanks Darby for the reply, 
I updated the Board Manager on Arduino IDE to 1.0.15 (also tried 1.0.16) --> the tried updating the Bootloader using Arduino IDE (but failed) with the following error message:

    Arduino: 1.8.5 (Linux), Board: "OpenCR Board, OpenCR Bootloader"

        at cc.arduino.packages.uploaders.SerialUploader.burnBootloader(SerialUploader.java:362)
        at processing.app.Editor.lambda$handleBurnBootloader$14(Editor.java:2519)
        at java.lang.Thread.run(Thread.java:748)
    Error while burning bootloader.

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.

I made sure the

>  lsusb

is showing the STMicroelectronics (NOTE: There is no DFU mode written as you mention in the emanual - but this entry in lsusb starts showing up only after DFU mode triggered on using Boot + Reset button)

    Bus 002 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 002: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
    Bus 003 Device 006: ID 0483:5740 STMicroelectronics STM32F407
    Bus 003 Device 004: ID 0765:5010 X-Rite, Inc. 
    Bus 003 Device 003: ID 8087:07dc Intel Corp. 
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can you let me know some tips to go ahead with debugging?


[Visit Topic](https://discourse.ros.org/t/turtlebot3-software-and-firmware-update-and-waffle-pi/3729/17) or reply to this email to respond.

More information about the ros-users mailing list