[ros-users] Weird issues with camera1394

Miguel Prada miguel.register at gmail.com
Wed May 26 14:28:13 UTC 2010


I'm trying to replace a usb webcam I'm using for a firewire Unibrain Fire-i camera, but I'm having some trouble using it with ROS. There are two issues I honestly don't know how to deal with.

1- If I run camera1394_node using 'rosrun camera1394 camera1394_node' the camera seems to work, but when I try to visualize the images published on /camera/image_raw topic using image_view the image that shows is completely messed up. However, when I visualize the camera output with coriander it looks perfect. Check the images linked below to see what I mean.

camera1394->image_view:	http://www.flickr.com/photos/migueluli/4641459303/in/set-72157624016324875/
Coriander:					http://www.flickr.com/photos/migueluli/4641459171/in/set-72157624016324875/

2- If I use roslaunch instead of rosrun I'm unable to start the camera. I've tried to look at the two launch files found in camera1394 package, as well as the camera configuration yaml files, but I can't think of anything inside those that may cause this problems. For the output I get (pasted below), it looks like it has something to do with not being able to set the appropriate iso level on the camera, but I find it strange that the same doesn't happen when using rosrun.

One last thing that might be related. I have to give read and write permisions to /dev/raw1394 and /dev/video1394/0 for all users in order to make any of the above stated work at all.

Has anyone experienced similar problems? If so, have you fixed it? And how?


FATRONIK\mprada at pcf-264-0209l:~$ roslaunch camera1394 firewire_camera.launch
... logging to /home/FATRONIK/mprada/.ros/log/06ae162e-68c7-11df-aef6-00219be9ec9c/roslaunch-pcf-264-0209l-9962.log

started roslaunch server http://pcf-264-0209l:56076/


 * /unibrain/camera1394_node/camera_info_url
 * /unibrain/camera1394_node/guid
 * /unibrain/camera1394_node/video_mode

    camera1394_node (camera1394/camera1394_node)


core service [/rosout] found
process[camera1394_node-1]: started with pid [9980]
[ERROR] 1274883021.997175000: Unsupported iso_speed. Defaulting to 400.
libdc1394 error: Error: Failed to setup DMA capture
[FATAL] 1274883022.005991000: [camera] exception opening device: [Camera1394::open]: Failed to open device!

More information about the ros-users mailing list