[ros-users] roscd pointing to wrong folder

Aslund sebastian.aslund at gmail.com
Tue Feb 22 01:06:22 UTC 2011

Hey everyone

Earlier today I tried to install the OpenNI driver according to the tutorial
on the ROS homepage, but the result turned my ROS installation into a total
mess. The driver was unable to install due to some part of openCV missing,
but I was unable to install them since roscd suddenly pointed to the
ros/unstable folder instead of ros/cturtle.
I tried to remove ROS and install it again in hope that would help, but
seems the path is defined in some bash file, but I have no clue where or how
to change it back so my ROS works again.
Furthermore, then during the installation of the new ROS I got a few
messages like this one "sh: getcwd() failed: No such file or directory", is
it also caused by his failure in roscd or some other problem, never
experienced this message during the installation of ROS through the
Last but not least, it is not possible to install the OpenNI driver without
involving creating the unstable folder? Since it seems that it creates more
harm than good.

Thanks for your help

Sebastian Aslund
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110222/27ed6b4c/attachment-0002.html>

More information about the ros-users mailing list