[ros-users] Pyyaml using easy_install on Mac OS X

S.Sudarshan sudarshan85 at gmail.com
Thu Mar 17 03:56:04 UTC 2011


I finally fixed it. Just letting everyone know in case someone else has a
similar problem. Basically, the problem with the pyyaml installation is, Mac
OS X comes with a Python installation (2.5) which is located at

Soft links for python, python-config, python2.5 etc for execs located in the
above folder are available at /usr/bin.

Now Macports installs its own version of python (2.6 for ROS) which is
located at

Now, there are also multiple versions of easy_install the default one
catering to python version 2.5. So if we do sudo easy_install -U rosinstall,
rosinstall gets installed at /usr/local/bin and when launched references the
original python version that came with Mac OS X. Making sure that the
Macports bin path appears before /usr/bin doesnt fix this problem. So what I
ended up doing is removing the soft links in /usr/bin for the original
python installation. Then I used easy_install-2.6 to install rosinstall.
Now, heres the tricky part, using this command installs rosinstall
at /opt/localLibrary/Frameworks/Python.framework/Versions2.6/bin/rosinstall
and /opt/localLibrary/Frameworks/Python.framework/Versions2.6/bin/roslocate.
However, these are not included into the PATH variable by defualt. So, I
just soft linked rosinstall and roslocate to /opt/local/bin and ran
rostinstall. And everything works now! (well it seems to be installing).

Thanks everyone for your help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110316/54edd1c2/attachment-0003.html>

More information about the ros-users mailing list