[ros-users] [Discourse.ros.org] [Next Generation ROS] Failed to read 'request_type' from a header for /rostopic

Arunava Nag ros.discourse at gmail.com
Thu Oct 5 02:42:46 UTC 2017

[quote="marguedas, post:2, topic:2759"]
ros2 topic echo /joint_states sensor_msgs/JointState

Hi @marguedas,
Everything works now. Thanks. However please let me know how to get rid of the warning i am receiving as mentioned in  [here](https://discourse.ros.org/t/failed-to-read-request-type-from-a-header-for-rostopic/2759/9?u=arunava_nag)

So, does it imply that i can only read or echo on ros2 side, when i do rostopic pub?
You dont need a UR, I just tried with its gazebo simulation as [here](http://wiki.ros.org/ur_gazebo), it streams out the topic /joint_states when I launch the ur10.launch file, however establishing the ros_bridge I still couldn't hear those messages in ros2 end.

[Visit Topic](https://discourse.ros.org/t/failed-to-read-request-type-from-a-header-for-rostopic/2759/10) or reply to this email to respond.

More information about the ros-users mailing list